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AE-200E/AE-50E/EW-50E
Update Tool Instruction Book

<ORIGINAL>

Before using the controller, 
please read this Instruction 
Book carefully to ensure proper 
operation.
Retain this manual for future 
reference.

For distribution to dealers and contractors
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Terms used in this manual
- �“Centralized Controller AE-200A/AE-200E” is referred to as “AE-200”.
- �“Centralized Controller AE-50A/AE-50E” is referred to as “AE-50”.
- �“Centralized Controller EW-50A/EW-50E” is referred to as “EW-50”.
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1.	 Introduction
1-1. What is AE-200 Update Tool?

Update Tool is a tool that can update the software of all AE-200/AE-50/EW-50 controllers that are connected in the 
air conditioning control system at once.

1-2. PC requirements
Item Requirements

CPU 1 GHz or better (at least 2 GHz recommended)
Memory 2 GB or better
Screen resolution 1024 x 768 or better

OS

Windows 7 (32bit/64bit)
Windows 8.1 (64bit)
Windows 10 (64bit)
** .NET Framework 4.0 or later is required.

Internal LAN port or LAN card 100 BASE-TX or better

Pointing device Mouse, etc.

Max. 50 controllers

AE-200/AE-50/EW-50

Update file

PC

Update file

Update file
AE-200/AE-50/EW-50

AE-200/AE-50/EW-50
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1-3. System descriptions
The system configuration image is shown below.

Important

• When connecting the AE-200/AE-50/EW-50 via a LAN, be sure to use the “LAN1” port.

AE-200AE-200

PC

LAN
HUB

HUB

AE-50/EW-50

AE-50/EW-50

HUB

AE-50/EW-50

AE-50/EW-50

AE-50/EW-50

AE-50/EW-50

Max. 50 controllers

AE-50/EW-50

AE-50/EW-50
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1-4. System restrictions
• AE-200 Update Tool is exclusively used for AE-200/AE-50/EW-50. Do not use this tool for other products.
• The AE-200/AE-50/EW-50 software cannot be downgraded to an earlier version.
• Up to 50 AE-200/AE-50/EW-50 controllers can be updated at the same time.

Note

• The communication between AE-200/AE-50/EW-50 and the air conditioning units will stop while the software 
is being updated. Although the unit in operation may detect a communication error and an error sign may 
appear on the local remote controllers, the unit will continue its operation and be operable from the local 
remote controllers.

** Note that Mr. Slim indoor units or systems with no local remote controllers may detect a communication error and come to an abnormal 
stop.

• While the software is being updated, up to 60-minute worth of energy management data and billing function 
data will not be recorded.
• When an AE-50/EW-50’s Pulse Input (PI) function is used, the pulse that is input while the software is being 

updated will not be counted.

Important

• Record the operation status of the air conditioning units immediately before updating the software. After the 
software update is completed, check the operation status of the units, and manually operate the units as 
necessary.
• Some operations and functions, such as scheduled operations, billing function, Peak Cut control, energy 

management function, will be disabled while the software is being updated. Check the setting details of these 
functions beforehand, and update the software when it does not affect these functions.
• If the functions in the table below are used, avoid updating the AE-200/AE-50/EW-50 software during the time 

period indicated in the right column.

Function in use Time period in which the update is prohibited
Electricity charge apportioning function  
(with Charge Calculation Tool) AM 5:00 – 5:10

Electricity charge apportioning function (with TG-2000A) AM 4:05 – 4:35
Malfunction log backup (with TG-2000A) AM 0:05 – 0:15
Peak Cut data backup (with TG-2000A) AM 2:00 – 2:10
Measurement trend data backup  
(with PI controller, AI controller, or TG-2000A) AM 1:05 – 1:15
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2.	 Preparation
2-1. How to obtain the update file

For how to obtain the latest update file, contact the dealer from which the Update Tool was obtained.

2-2. Installation procedures of Update Tool
Important

• If your OS is Windows 7, check beforehand that .NET Framework version 4.0 or later is installed.  
Refer to section 2-4 “Installation procedures of .NET Framework” for details. 

Note

• The version of the installed .NET Framework can be checked by selecting the Windows Start menu and then 
choosing [Control Panel] > [Program and Features].

Procedures

1. Double-click “AE-200 UpdateTool_V***.msi” that was downloaded. 
** “V***” indicates version number. (“V100” indicates Ver. 1.00.)

2. If the “Security Warning” message appears, click [Run].

3. When the “Setup Wizard” screen appears, click [Next].

4. The “License Agreement” screen will appear. Read through, 
select [I Agree], and click [Next].
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5. The “Select Installation Folder” screen will appear. Select the 
save destination folder and click [Next].

Note

• To allow all users who can login the PC to have access to the 
Update Tool, check that the [Everyone] checkbox is selected 
and then click [Next].

6. When the “Confirm Installation” screen appears, click [Next].

7. The Update Tool will be installed.

8. Once installation is completed, click [Close].
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2-3. Setting the PC’s IP address
Set the PC’s IP address so that settings data can be sent from the Update Tool to the AE-200/AE-50/EW-50. 
When setting the PC’s IP address, set a network address in the same system as the IP address for the 
AE-200/AE-50/EW-50.
(Example: AE-200 IP address: 192.168.11.1; PC IP address: 192.168.11.150)
When connecting the AE-200/AE-50/EW-50 to an existing LAN, consult the system administrator to decide the IP 
address.

Procedures

1. Click [Control Panel] in the Start menu.

2. Click [Network and Sharing Center] > [Local Area Connection].

3. In the “Local Area Connection Status” window, click [Properties].

4. Click [Internet Protocol Version 4 (TCP/IPv4)] to select it, and click 
[Properties].
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5. In the [Internet Protocol Version 4 (TCP/IPv4) Properties] window, 
check the radio button next to [Use the following IP address].

6. Enter the PC’s IP address (e.g., [192.168.11.150]) in “IP address”.

7. Enter the subnet mask [255.255.255.0] (unless otherwise specified) 
in “Subnet mask”.

8. In “Default gateway”, enter the gateway address as necessary.

Important

• �Consult the system administrator to decide the IP, subnet mask, and gateway addresses.
• Take a note of the IP, subnet mask, and gateway addresses before changing them.

9. Keep clicking [OK] or [Close] to close all windows.

2-4. Installation procedures of .NET Framework
If .NET Framework 4.0 is not already installed, download the .NET Framework 4.5.2 installer from the URL shown 
below, and then install it.

URL for when the Internet is connected (Web installer) (English):
http://www.microsoft.com/en-US/download/details.aspx?id=42643

URL for when the Internet is not connected (Offline installer) (English):
http://www.microsoft.com/en-US/download/details.aspx?id=42642

** Other language can also be selected from this website.

Important

• �If the system is not connected to the Internet, you will need to download the offline installer beforehand.
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3.	 Usage instructions
See the entire flowchart below to use the Update Tool. For details of each process, refer to the reference section 
shown in the table below.

Process Reference section

(1) Main screen 3-1 “Main screen”

(2) Inputting IP address of centralized controller 3-2 “Inputting IP address of centralized controller”

(3) Checking the version of the centralized controller 3-3 “Checking the version of the centralized controller”

(4) Selecting the update file 3-4 “Selecting the update file”

(5) Authentication information input screen 3-5 “Updating the centralized controllers”

(6) Update 3-5 “Updating the centralized controllers”

(7) Confirming update completion 3-5 “Updating the centralized controllers”

(1) Main screen

(2) ‌Inputting IP address of centralized controller

(3) ‌Checking the version of the centralized controller

(4) ‌Selecting the update file

Click “Acquire data”.

(5) ‌Authentication information input screen

Click “Update”.

(6) ‌Update

Enter ID and password, and click “OK”.

(7) ‌Confirming update completion
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3-1. Main screen
3-1-1. Screen configuration

When the Update Tool is started up, a main screen will appear.

Function Operation method Description

①

Menu bar Operations such as to load the TXT file 
in which the destination IP addresses are 
entered, save the entered destination IP 
addresses, exit the Update Tool, and to 
check the version information are possible.

Refer to sections 3-1-2 “List of menu bar 
operations”, 3-2-2 “When loading IP addresses 
from TXT file”, and 3-6 “Saving the IP 
addresses of centralized controllers”.

② Update file selection Select the update file for the centralized 
controller.

Refer to section 3-4 “Selecting the update file”.

③
IP address setting The area in which settings of the IP address 

of the centralized controller to be updated 
are made.

Refer to section 3-2 “Inputting IP address of 
centralized controller”.

④ Centralized controller 
system information

The system information of a given 
centralized controller is displayed.

⑤ Centralized controller 
status

The status regarding the update of a given 
centralized controller is displayed.

⑥
[Acquire data] Click to acquire the system information of 

the centralized controllers whose IP address 
is entered in the IP address setting area.

Refer to section 3-3 “Checking the version of 
the centralized controller”.

⑦
[Update] Click to update the centralized controllers 

whose IP address is entered in the IP 
address setting area.

Refer to section 3-5 “Updating the centralized 
controllers”.

Note

• Up to 50 centralized controllers can be updated at the same time.

① Menu bar

③ IP address setting

④ Centralized controller 
system information

② Update file selection

⑤ ‌�Centralized controller 
status

⑦ ‌�[Update]

⑥ [Acquire data]



12WT08302X01

3-1-2. List of menu bar operations

[1] 	Open TXT file
Click [File] > [Open] in the menu bar to load the TXT file in which the destination IP addresses are entered.

[2] 	Save TXT file
Click [File] > [Save] in the menu bar to save the IP addresses that are entered in the IP address setting area on the 
PC.

[3] 	Exit Update Tool
Click [File] > [Exit] in the menu bar to exit the Update Tool.

[4] 	Version information
Click [Help] > [About] in the menu bar to display the version of the current Update Tool. (The sample screen below 
is a screen when the Update Tool is Ver. 1.00.)

File
Executes [1] Open TXT file, 
[2] Save TXT file, and [3] Exit 
Update Tool.

Help
Displays [4] version information 
of this software.
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3-2. Inputting the IP addresses of centralized controllers
3-2-1. When inputting IP addresses directly

Procedures

1. Enter the IP address of the centralized controller to be updated in each “Destination IP address” column.

Important

• Enter the IP address in one-byte characters in the following formula. 
[XXX.XXX.XXX.XXX] (XXX: Integer number between 0 and 255)  
Example: [192.168.1.1]
Do not enter any characters other than the above (including tab and space).

3-2-2. When loading IP addresses from TXT file
Note

• The Update Tool can load the IP addresses of the centralized controllers that were entered in the TXT file.

Procedures

1. Using a notepad etc, create a file of the IP address data of the centralized controllers in a TXT file.

Note

• Up to 50 IP addresses can be loaded.
• When only line feed is inserted, it will appear as a blank line. 

Important

• Enter the IP address in one-byte characters in the following formula. 
[XXX.XXX.XXX.XXX] (XXX: Integer number between 0 and 255)  
Example: [192.168.1.1]
Do not enter any characters other than the above (including tab and space).
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2. Click [File] > [Open].

3. A screen to select a file will appear. Select the TXT file that was created in step 1 above, and click [Open].

4. The IP addresses of the centralized controllers to be updated will be loaded and displayed in the “Destination 
IP address” column.
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3-3. Checking the versions of the centralized controllers
Procedures

1. Click [Acquire data].

2. The information shown in the next page will appear in the “Status” column for each destination IP address. 
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Display information in the “Status” column Explanation

1 Acquiring data... The centralized controller data are being acquired. 
The message will appear in black.

2 

Data acquisition succeeded The centralized controller data have been successfully acquired.
The message will appear in black.
When the data acquisition is successfully completed, the model name, 
version, and serial number of the centralized controller will be displayed 
on the main screen.

3 Data acquisition failed The centralized controller data have failed to be acquired.
The message will appear in red.

4 
Invalid IP address The IP address entered in “Destination IP address” is not in the correct 

format. 
The message will appear in red.

5 IP addresses overlap The IP addresses entered in “Destination IP address” overlap.
The message will appear in red.

6 

The equipment is not applicable for 
update.

The data of the equipment that is not an update target 
(AE-200/AE-50/EW-50) have been successfully acquired.
The message will appear in red.
When this message appears, the model name, version, and serial 
number of the centralized controller will be displayed on the main 
screen.

Note

• When “Data acquisition failed,” “Invalid IP address,” or “IP addresses overlap” appears in the “Status” column 
of the main screen, refer to section 4 “Troubleshooting”.
• On the main screen, the centralized controller model name is displayed in “Model name,” the current software 

version of the centralized controller is displayed in “Version,” and the centralized controller serial number is 
displayed in “Serial No.”.

Important

• Do not click  at the top right corner of the main screen while the data is being acquired.
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3-4. Selecting the update file
Procedures

1. Click [Browse...].

2. A screen to select a file will appear. Select the update file, and click [Open].

3. If the update file exists, the file name will be displayed in the text box.

Note

• Select “AE200_FW####_****.dat” for an update file for AE-200. (####: software version)
• Select “AE50_FW####_****.dat” for an update file for AE-50/EW-50. (####: software version)
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3-5. Updating the centralized controllers
Procedures

1. Click [Update] to display the “Authentication information input” screen.

2. Enter the ID and password for initial settings for the centralized controller to be updated.  
If the ID and password are the same as the ones for the centralized controller No. 1, check the checkbox next 
to [Same as No. 1].

Note

• For No. 2 or later, even when the IP address is not displayed in the “Destination IP address” column of No. 1, 
if [Same as No. 1] is checked, the same ID and password as the ones for No. 1 can be used.

3. Click [OK] on the “Authentication information input” screen. The screen will close and the update will start.

Destination IP address
The IP address of the 

centralized controller to be 
updated will appear.

ID entry field
Enter the ID for initial 
settings for the centralized 
controller.

Centralized controller No.

Password entry field
Enter the password for initial 
settings for the centralized 
controller.

[Same as No. 1] checkbox
Check to use the same ID 
and password as the ones 

for the centralized controller 
No. 1.
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4. The update status will appear in the “Status” column of the main screen.

Display information in the “Status” column Explanation Display order

1 
Authentication succeeded The centralized controller authentication has been 

successfully completed. 
The message will appear in black.

1
2 Authentication failed The centralized controller authentication has failed.

The message will appear in red.

3 Communication failed The centralized controller communication has failed.
The message will appear in red.

4 Already updated The centralized controller is already updated.
The message will appear in red.

5 Updating... The centralized controller is being updated.
The message will appear in black. 2

6 
Update completed The centralized controller update has been successfully 

completed.
The message will appear in black. 3

7 Update failed The centralized controller update has failed.
The message will appear in red.
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Note

• The following is the approximate time required for update. The time varies with the number of centralized 
controllers and software versions. 

Time required for update [min]

Number of centralized 
controllers to be updated Ver. 7.24 or earlier Ver. 7.31 or later

4 9 7
10 15 10
20 25 15
40 45 25
50 55 30

• The following centralized controllers will not be updated.
- No destination IP address is entered.
- ‌�“The equipment is not applicable for update.” or “Already updated” is displayed in the “Status” column of 

the main screen.
• When “Authentication failed,” “Communication failed,” or “Update failed” appears in the “Status” column of the 

main screen, refer to section 4 “Troubleshooting”.
• The following 7905 error message may appear on the AE-200 during the update process if the software 

versions of AE-200 and all AE-50/EW-50 that are connected to the AE-200 temporarily do not match.
** The error will automatically be reset when the software versions match.

Important

• Do not click  at the top right corner of the main screen, disconnect the LAN cable, or turn off the power to 
the AE-200/AE-50/EW-50 during the update process.
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3-6. Saving the IP addresses of centralized controllers
1. Click [File] > [Save].

2. A screen to select a file will appear. Specify any arbitrary name in “File name”, and click [Save].

Note

• When the saving the IP addresses is completed, the following window will appear.
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4.	 Troubleshooting
See the table below and troubleshoot accordingly.

No. Problem Possible cause Solution

1 

An error occurs 
when the TXT file 
is loaded.

• The TXT file is not 
created according to 
the specified format.

• Check if the TXT file 
is created according 
to the specified 
format in section 3-2-
2 “When loading IP 
addresses from TXT 
file”.

2 

An error occurs 
when the update 
file is selected.

• A wrong file is 
selected.

• Check if the name 
of the selected 
file is “AE200_
FW####_****.dat”. 
(####: software 
version)  
Then, re-select the 
correct file.

3 

• A wrong file is 
selected.

• Check if the name 
of the selected file is 
“AE50_FW####_****.
dat”. (####: software 
version)  
Then, re-select the 
correct file.

4 

An error occurs 
when the 
centralized 
controller data is 
acquired.

The message “Data acquisition failed” 
appears in the “Status” column of the main 
screen.

• The IP address of the 
centralized controller 
is different from the 
one entered in the 
main screen.

• The LAN connection 
with the centralized 
controller entered in 
the “Destination IP 
address” column is 
not established.

• Check if the IP 
address of the 
centralized controller 
is correct. Then, 
enter the correct IP 
address.

• Check for proper LAN 
connection between 
the PC with the 
Update Tool installed 
and the centralized 
controller.

5 

The message “Invalid IP address” appears in 
the “Status” column of the main screen.

• The IP address is not 
entered according to 
the specified format.

• Check if the IP 
address is entered 
according to the 
specified format 
in section 3-2 
“Inputting IP address 
of centralized 
controller”.

6 

The message “IP addresses overlap” appears 
in the “Status” column of the main screen.

• The IP addresses 
entered in 
“Destination IP 
address” of the main 
screen overlap.

• Check the IP 
address of the given 
centralized controller 
in error, and re-
enter the correct IP 
address.
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No. Problem Possible cause Solution

7 

An error occurs 
when [Update] is 
clicked on the main 
screen.

• The data acquisition 
of all centralized 
controllers has not 
been completed.

• Check the 
“Destination IP 
address” and “Status” 
columns of the main 
screen to see if there 
are any centralized 
controllers whose 
data have not been 
acquired. Then, click 
[Acquire data] on 
the main screen to 
complete the data 
acquisition.

8 

• The update file 
for AE-200 is not 
selected.

• Click [Browse...] for 
AE-200 and select the 
correct update file.

9 

• The update file for 
AE-50/EW-50 is not 
selected.

• Click [Browse...] for 
AE-50/EW-50 and 
select the correct 
update file.

10 

• The version of the 
selected update file is 
older than the version 
of AE-200. 

• Click [Browse...] for 
AE-200 and select 
the update file whose 
version is earlier 
than the version of 
AE-200. 

11 

• The version of the 
selected update file is 
older than the version 
of AE-50/EW-50. 

• Click [Browse...] 
for AE-50/EW-50 
and select the 
update file whose 
version is earlier 
than the version of 
AE-50/EW-50. 

12 

• The versions of the 
update file for AE-200 
and the update file for 
AE-50/EW-50 do not 
match.

• Check the versions 
of the update file 
for AE-200 and 
the update file for 
AE-50/EW-50. 
Then, re-select the 
update file so that 
the versions of them 
match.
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No. Problem Possible cause Solution

13 

An error occurs 
when the 
centralized 
controllers are 
updated.

• The LAN connection 
with the centralized 
controller is cut off.

• The ID and password 
of the centralized 
controller entered in 
the authentication 
information input 
screen are wrong.

• Check for proper LAN 
connection between 
the PC with the 
Update Tool installed 
and the given 
centralized controller 
in error.

• Re-enter the ID and 
password for initial 
settings for the given 
centralized controller 
in error.

14 

The message “Update failed” appears in the 
“Status” column of the main screen.

• The LAN connection 
with the centralized 
controller is cut off 
during the update 
process.

• The centralized 
controllers cannot 
properly be 
updated due to the 
communication failure 
etc.

• Check for proper LAN 
connection between 
the PC with the 
Update Tool installed 
and the centralized 
controller. Then, click 
[Acquire data] on the 
main screen to see 
if the version of the 
centralized controller 
has been updated. If 
not properly updated, 
update again.
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This product is designed and intended for use in the residential,  
commercial and light-industrial environment.

The product at hand is based on the following EU regulations:
•	Low Voltage Directive 2014/35/EU
•	Electromagnetic Compatibility Directive 2014/30/EU
•	Restriction of Hazardous Substances 2011/65/EU

Please be sure to put the contact address/telephone number  
on this manual before handing it to the customer.

HEAD OFFICE: TOKYO BLDG., 2-7-3, MARUNOUCHI, CHIYODA-KU, TOKYO 100-8310, JAPAN
MANUFACTURER: ‌�MITSUBISHI ELECTRIC CORPORATION  Air-conditioning & Refrigeration Systems Works  

5-66, Tebira 6 Chome, Wakayama-city, 640-8686, Japan WT08302X01
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